// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\.\.\/.*temp").unwrap();
let string = "<p><img class=\"m-4\" src=\"../../../img/page/temp/dd2b0a2c5925e4f55da1992456eb9ef8.webp\" alt=\"\" width=\"295\" height=\"360\"></p>";
let substitution = "url_id_page_";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}