#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/((?<prefix>[^\s\/]+)\/)*(?<fileName>.*)"
Local $sString = "1.(here file name should be data.csv)" & @CRLF & _
"/home/data/var/log/ data.csv" & @CRLF & _
"" & @CRLF & _
" 2.It doesn't have space after log" & @CRLF & _
" /home/data/var/log/data.csv" & @CRLF & _
" " & @CRLF & _
" 3.It has space with after log but file extension is different.(here file name is (data2015067987.dat)" & @CRLF & _
" /home/data/var/log/ data2015067987.dat" & @CRLF & _
" /home/data/var/log/ 201608587data.csv" & @CRLF & _
" " & @CRLF & _
" 4.(here file name is data data2 data3)" & @CRLF & _
" /home/data/var/log/ data data2 data3 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")