const regex = /\/((?<prefix>[^\s\/]+)\/)*(?<fileName>.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/((?<prefix>[^\\s\\\/]+)\\\/)*(?<fileName>.*)', 'g')
const str = `1.(here file name should be data.csv)
/home/data/var/log/ data.csv
2.It doesn't have space after log
/home/data/var/log/data.csv
3.It has space with after log but file extension is different.(here file name is (data2015067987.dat)
/home/data/var/log/ data2015067987.dat
/home/data/var/log/ 201608587data.csv
4.(here file name is data data2 data3)
/home/data/var/log/ data data2 data3 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}