import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/((?<prefix>[^\\s\\/]+)\\/)*(?<fileName>.*)";
final String string = "1.(here file name should be data.csv)\n"
+ "/home/data/var/log/ data.csv\n\n"
+ " 2.It doesn't have space after log\n"
+ " /home/data/var/log/data.csv\n"
+ " \n"
+ " 3.It has space with after log but file extension is different.(here file name is (data2015067987.dat)\n"
+ " /home/data/var/log/ data2015067987.dat\n"
+ " /home/data/var/log/ 201608587data.csv\n"
+ " \n"
+ " 4.(here file name is data data2 data3)\n"
+ " /home/data/var/log/ data data2 data3 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}