package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/((?<prefix>[^\s\/]+)\/)*(?<fileName>.*)`)
var str = `1.(here file name should be data.csv)
/home/data/var/log/ data.csv
2.It doesn't have space after log
/home/data/var/log/data.csv
3.It has space with after log but file extension is different.(here file name is (data2015067987.dat)
/home/data/var/log/ data2015067987.dat
/home/data/var/log/ 201608587data.csv
4.(here file name is data data2 data3)
/home/data/var/log/ data data2 data3 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}