# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/((?<prefix>[^\s\/]+)\/)*(?<fileName>.*)"
test_str = ("1.(here file name should be data.csv)\n"
"/home/data/var/log/ data.csv\n\n"
" 2.It doesn't have space after log\n"
" /home/data/var/log/data.csv\n"
" \n"
" 3.It has space with after log but file extension is different.(here file name is (data2015067987.dat)\n"
" /home/data/var/log/ data2015067987.dat\n"
" /home/data/var/log/ 201608587data.csv\n"
" \n"
" 4.(here file name is data data2 data3)\n"
" /home/data/var/log/ data data2 data3 ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.