// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/((?<prefix>[^\s\/]+)\/)*(?<fileName>.*)").unwrap();
let string = "1.(here file name should be data.csv)
/home/data/var/log/ data.csv
2.It doesn't have space after log
/home/data/var/log/data.csv
3.It has space with after log but file extension is different.(here file name is (data2015067987.dat)
/home/data/var/log/ data2015067987.dat
/home/data/var/log/ 201608587data.csv
4.(here file name is data data2 data3)
/home/data/var/log/ data data2 data3 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}