# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img.*src='?"?(.*?)'?"?\\/?>/$1/gm;t' <<< "<img src=\"http://abc.png\">
<img src='http://abc.png'>
<img src='https://abc.png'>
<img src='http://abc.png'/>
<img src='http://abc.jpg'>
<img class=\"abc\" src='http://abc.jpeg'>
"