const regex = /<img.*src='?"?(.*?)'?"?\/?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.*src=\'?"?(.*?)\'?"?\\\/?>', 'gm')
const str = `<img src="http://abc.png">
<img src='http://abc.png'>
<img src='https://abc.png'>
<img src='http://abc.png'/>
<img src='http://abc.jpg'>
<img class="abc" src='http://abc.jpeg'>
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);