#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<img.*src='?"?(.*?)'?"?\/?>"
Local $sString = "<img src="http://abc.png">" & @CRLF & _
"<img src='http://abc.png'>" & @CRLF & _
"<img src='https://abc.png'>" & @CRLF & _
"<img src='http://abc.png'/>" & @CRLF & _
"<img src='http://abc.jpg'>" & @CRLF & _
"<img class="abc" src='http://abc.jpeg'>" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)