using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img.*src='?""?(.*?)'?""?\/?>";
string substitution = @"$1";
string input = @"<img src=""http://abc.png"">
<img src='http://abc.png'>
<img src='https://abc.png'>
<img src='http://abc.png'/>
<img src='http://abc.jpg'>
<img class=""abc"" src='http://abc.jpeg'>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}