use strict;
my $str = '<img src="http://abc.png">
<img src=\'http://abc.png\'>
<img src=\'https://abc.png\'>
<img src=\'http://abc.png\'/>
<img src=\'http://abc.jpg\'>
<img class="abc" src=\'http://abc.jpeg\'>
';
my $regex = qr/<img.*src='?"?(.*?)'?"?\/?>/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";