import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.*src='?\"?(.*?)'?\"?\\/?>";
final String string = "<img src=\"http://abc.png\">\n"
+ "<img src='http://abc.png'>\n"
+ "<img src='https://abc.png'>\n"
+ "<img src='http://abc.png'/>\n"
+ "<img src='http://abc.jpg'>\n"
+ "<img class=\"abc\" src='http://abc.jpeg'>\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}