#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!\s)((\d*\.?\d*)*|([+*^\.\(\)\-])*?)?"
Local $sString = "This one works for value.match() in JS" & @CRLF & _
"/(?!\s)(([+\-*^()])|(\d*\.?\d*)*)/gm" & @CRLF & _
"" & @CRLF & _
"The one in the bar shows how it collects the values" & @CRLF & _
"" & @CRLF & _
"7 + 5" & @CRLF & _
"7+ 5" & @CRLF & _
"7 +5" & @CRLF & _
"5 + 7" & @CRLF & _
"6 * 5" & @CRLF & _
"6 ^ 5" & @CRLF & _
"6 - 5" & @CRLF & _
"(60 + 5) * 4" & @CRLF & _
"( 70 + 5) + 4" & @CRLF & _
"+4" & @CRLF & _
"*657" & @CRLF & _
"(*6)" & @CRLF & _
"7.6656" & @CRLF & _
"( 6.54 + 5) * 33.4" & @CRLF & _
"+-^*()00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")