$re = '/(?!\s)((\d*\.?\d*)*|([+*^\.\(\)\-])*?)?/m';
$str = 'This one works for value.match() in JS
/(?!\\s)(([+\\-*^()])|(\\d*\\.?\\d*)*)/gm
The one in the bar shows how it collects the values
7 + 5
7+ 5
7 +5
5 + 7
6 * 5
6 ^ 5
6 - 5
(60 + 5) * 4
( 70 + 5) + 4
+4
*657
(*6)
7.6656
( 6.54 + 5) * 33.4
+-^*()00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);