import Foundation
let pattern = #"(?!\s)((\d*\.?\d*)*|([+*^\.\(\)\-])*?)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This one works for value.match() in JS
/(?!\s)(([+\-*^()])|(\d*\.?\d*)*)/gm
The one in the bar shows how it collects the values
7 + 5
7+ 5
7 +5
5 + 7
6 * 5
6 ^ 5
6 - 5
(60 + 5) * 4
( 70 + 5) + 4
+4
*657
(*6)
7.6656
( 6.54 + 5) * 33.4
+-^*()00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)