const regex = /(?!\s)((\d*\.?\d*)*|([+*^\.\(\)\-])*?)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\s)((\\d*\\.?\\d*)*|([+*^\\.\\(\\)\\-])*?)?', 'gm')
const str = `This one works for value.match() in JS
/(?!\\s)(([+\\-*^()])|(\\d*\\.?\\d*)*)/gm
The one in the bar shows how it collects the values
7 + 5
7+ 5
7 +5
5 + 7
6 * 5
6 ^ 5
6 - 5
(60 + 5) * 4
( 70 + 5) + 4
+4
*657
(*6)
7.6656
( 6.54 + 5) * 33.4
+-^*()00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}