import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\s)((\\d*\\.?\\d*)*|([+*^\\.\\(\\)\\-])*?)?";
final String string = "This one works for value.match() in JS\n"
+ "/(?!\\s)(([+\\-*^()])|(\\d*\\.?\\d*)*)/gm\n\n"
+ "The one in the bar shows how it collects the values\n\n"
+ "7 + 5\n"
+ "7+ 5\n"
+ "7 +5\n"
+ "5 + 7\n"
+ "6 * 5\n"
+ "6 ^ 5\n"
+ "6 - 5\n"
+ "(60 + 5) * 4\n"
+ "( 70 + 5) + 4\n"
+ "+4\n"
+ "*657\n"
+ "(*6)\n"
+ "7.6656\n"
+ "( 6.54 + 5) * 33.4\n"
+ "+-^*()00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}