import re
regex = re.compile(r"(?!\s)((\d*\.?\d*)*|([+*^\.\(\)\-])*?)?", flags=re.MULTILINE)
test_str = ("This one works for value.match() in JS\n"
"/(?!\\s)(([+\\-*^()])|(\\d*\\.?\\d*)*)/gm\n\n"
"The one in the bar shows how it collects the values\n\n"
"7 + 5\n"
"7+ 5\n"
"7 +5\n"
"5 + 7\n"
"6 * 5\n"
"6 ^ 5\n"
"6 - 5\n"
"(60 + 5) * 4\n"
"( 70 + 5) + 4\n"
"+4\n"
"*657\n"
"(*6)\n"
"7.6656\n"
"( 6.54 + 5) * 33.4\n"
"+-^*()00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")