# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S*(?:(['"`]).*?\2)\S*)\s?|\s/\1\n/g;t' <<< "Split on spaces, except \"for this\", and 'this section', and `ignore this too`."