import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S*(?:(['\"`]).*?\\2)\\S*)\\s?|\\s";
final String string = "Split on spaces, except \"for this\", and 'this section', and `ignore this too`.";
final String subst = "\\1\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}