import Foundation
let pattern = #"(\S*(?:(['"`]).*?\2)\S*)\s?|\s"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Split on spaces, except "for this", and 'this section', and `ignore this too`."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)