$re = '/(\S*(?:([\'"`]).*?\2)\S*)\s?|\s/';
$str = 'Split on spaces, except "for this", and \'this section\', and `ignore this too`.';
$subst = "\1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;