re = /(\S*(?:(['"`]).*?\2)\S*)\s?|\s/
str = 'Split on spaces, except "for this", and \'this section\', and `ignore this too`.'
subst = '\\1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result