using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S*(?:(['""`]).*?\2)\S*)\s?|\s";
string substitution = @"\1\n";
string input = @"Split on spaces, except ""for this"", and 'this section', and `ignore this too`.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}