import re
regex = re.compile(r"(\S*(?:(['\"`]).*?\2)\S*)\s?|\s")
test_str = "Split on spaces, except \"for this\", and 'this section', and `ignore this too`."
subst = "\\1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)