const regex = /(\S*(?:(['"`]).*?\2)\S*)\s?|\s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S*(?:([\'"`]).*?\\2)\\S*)\\s?|\\s', 'g')
const str = `Split on spaces, except "for this", and 'this section', and \`ignore this too\`.`;
const subst = `\1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);