#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(edit[\s\S]{0,}?service ("ALL")[\s\S]{0,}?next)"
Local $sString = " edit 1035" & @CRLF & _
" set schedule "always"" & @CRLF & _
" set service "ALL"" & @CRLF & _
" set utm-status enable" & @CRLF & _
" next" & @CRLF & _
" edit 103" & @CRLF & _
" set schedule "always"" & @CRLF & _
" set service "ALL"" & @CRLF & _
" set utm-status enable" & @CRLF & _
" next"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")