$re = '/(edit[\s\S]{0,}?service ("ALL")[\s\S]{0,}?next)/';
$str = ' edit 1035
set schedule "always"
set service "ALL"
set utm-status enable
next
edit 103
set schedule "always"
set service "ALL"
set utm-status enable
next';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);