re = /(edit[\s\S]{0,}?service ("ALL")[\s\S]{0,}?next)/
str = ' edit 1035
set schedule "always"
set service "ALL"
set utm-status enable
next
edit 103
set schedule "always"
set service "ALL"
set utm-status enable
next'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end