package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(edit[\s\S]{0,}?service ("ALL")[\s\S]{0,}?next)`)
var str = ` edit 1035
set schedule "always"
set service "ALL"
set utm-status enable
next
edit 103
set schedule "always"
set service "ALL"
set utm-status enable
next`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}