const regex = /(edit[\s\S]{0,}?service ("ALL")[\s\S]{0,}?next)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(edit[\\s\\S]{0,}?service ("ALL")[\\s\\S]{0,}?next)', 'g')
const str = ` edit 1035
set schedule "always"
set service "ALL"
set utm-status enable
next
edit 103
set schedule "always"
set service "ALL"
set utm-status enable
next`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}