// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(edit[\s\S]{0,}?service ("ALL")[\s\S]{0,}?next)"#).unwrap();
let string = " edit 1035
set schedule \"always\"
set service \"ALL\"
set utm-status enable
next
edit 103
set schedule \"always\"
set service \"ALL\"
set utm-status enable
next";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}