using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(edit[\s\S]{0,}?service (""ALL"")[\s\S]{0,}?next)";
string input = @" edit 1035
set schedule ""always""
set service ""ALL""
set utm-status enable
next
edit 103
set schedule ""always""
set service ""ALL""
set utm-status enable
next";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}