import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(edit[\\s\\S]{0,}?service (\"ALL\")[\\s\\S]{0,}?next)";
final String string = " edit 1035\n"
+ " set schedule \"always\"\n"
+ " set service \"ALL\"\n"
+ " set utm-status enable\n"
+ " next\n"
+ " edit 103\n"
+ " set schedule \"always\"\n"
+ " set service \"ALL\"\n"
+ " set utm-status enable\n"
+ " next";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}