import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<figure[^>]*>[^>]*<img[^>]*src\\s*=\\s*\"\\K(.*?)(?=\" \\/>)";
final String string = "<img src=\"lorem.png\" />\n\n"
+ "<figure><img alt=\"\" src=\"test-image-1.png\" /><figcaption>test caption</figcaption></figure>\n\n"
+ "<figure><img alt=\"\" src=\"test-image-2-png\" /><figcaption>test caption 2</figcaption></figure>\n\n"
+ "<img src=\"ipsum.png />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}