re = /<figure[^>]*>[^>]*<img[^>]*src\s*=\s*"\K(.*?)(?=" \/>)/m
str = '<img src="lorem.png" />
<figure><img alt="" src="test-image-1.png" /><figcaption>test caption</figcaption></figure>
<figure><img alt="" src="test-image-2-png" /><figcaption>test caption 2</figcaption></figure>
<img src="ipsum.png />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end