import re
regex = re.compile(r"<figure[^>]*>[^>]*<img[^>]*src\s*=\s*\"\K(.*?)(?=\" \/>)", flags=re.MULTILINE | re.DOTALL)
test_str = ("<img src=\"lorem.png\" />\n\n"
"<figure><img alt=\"\" src=\"test-image-1.png\" /><figcaption>test caption</figcaption></figure>\n\n"
"<figure><img alt=\"\" src=\"test-image-2-png\" /><figcaption>test caption 2</figcaption></figure>\n\n"
"<img src=\"ipsum.png />")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")