$re = '/<figure[^>]*>[^>]*<img[^>]*src\s*=\s*"\K(.*?)(?=" \/>)/ms';
$str = '<img src="lorem.png" />
<figure><img alt="" src="test-image-1.png" /><figcaption>test caption</figcaption></figure>
<figure><img alt="" src="test-image-2-png" /><figcaption>test caption 2</figcaption></figure>
<img src="ipsum.png />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);