import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\t]*)(?:\\t([^\\t]*))?(?:\\t([^\\t]*))?(?:\\t([^\\t]*))?(?:\\t([^\\t]*))?$";
final String string = "Order 2187405 DvbzVvmLL\n"
+ "Order 4466605 drpTgPmm ItemPrice";
final String subst = "$1\\t$2\\t$3\\t$4\\t$5\\t481";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}