using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:0|-(?:0\.\d+|[1-9]\d*(?:\.\d+)?))$";
string input = @"0
00
-0.123
-0.000
0.123
-17
-017
-29.33
-29.00
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}