// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:0|-(?:0\.\d+|[1-9]\d*(?:\.\d+)?))$").unwrap();
let string = "0
00
-0.123
-0.000
0.123
-17
-017
-29.33
-29.00
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}