import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0|-(?:0\\.\\d+|[1-9]\\d*(?:\\.\\d+)?))$";
final String string = "0\n"
+ "00\n"
+ "-0.123\n"
+ "-0.000\n"
+ "0.123\n"
+ "-17\n"
+ "-017\n"
+ "-29.33\n"
+ "-29.00\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}