re = /^(?:0|-(?:0\.\d+|[1-9]\d*(?:\.\d+)?))$/m
str = '0
00
-0.123
-0.000
0.123
-17
-017
-29.33
-29.00
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end