const regex = new RegExp('^(?:0|-(?:0\\.\\d+|[1-9]\\d*(?:\\.\\d+)?))$', 'gm')
const str = `0
00
-0.123
-0.000
0.123
-17
-017
-29.33
-29.00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}