$re = '/^(?:0|-(?:0\.\d+|[1-9]\d*(?:\.\d+)?))$/m';
$str = '0
00
-0.123
-0.000
0.123
-17
-017
-29.33
-29.00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);