use strict;
my $str = '0
00
-0.123
-0.000
0.123
-17
-017
-29.33
-29.00
';
my $regex = qr/^(?:0|-(?:0\.\d+|[1-9]\d*(?:\.\d+)?))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}