import re
regex = re.compile(r"^(?:0|-(?:0\.\d+|[1-9]\d*(?:\.\d+)?))$", flags=re.MULTILINE)
test_str = ("0\n"
"00\n"
"-0.123\n"
"-0.000\n"
"0.123\n"
"-17\n"
"-017\n"
"-29.33\n"
"-29.00\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")