# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)(\+-|[\\/*+-])(?=\d)/$1 $2 /g;t' <<< "998998+999
998998+-999
99*8998+-999"