import re
regex = re.compile(r"(\d)(\+-|[\/*+-])(?=\d)")
test_str = ("998998+999\n"
"998998+-999\n"
"99*8998+-999")
subst = "$1 $2 "
result = regex.sub(subst, test_str)
if result:
print(result)